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Chapter 1: Up and 
Running with Excel

In This Chapter
✓ Creating an Excel workbook

✓ Understanding what a worksheet is

✓ Entering text, as well as numeric, date, and time data

✓ Using the AutoFill command to enter lists and serial data

✓ Establishing conditional formats for text

✓ Setting up data-validation rules

This chapter introduces Excel, the official number cruncher of Office 
2010. The purpose of Excel is to track, analyze, and tabulate numbers. 

Use the program to project profits and losses, formulate a budget, or ana-
lyze Elvis sightings in North America. Doing the setup work takes time, but 
after you enter the numbers and tell Excel how to tabulate them, you’re on 
Easy Street. Excel does the math for you. All you have to do is kick off your 
shoes, sit back, and see how the numbers stack up.

This chapter explains what a workbook and a worksheet are and how rows 
and columns on a worksheet determine where cell addresses are. You also 
discover tips and tricks for quickly entering data in a worksheet, and how to 
construct data-validation rules to make sure that data is entered accurately.

Creating a New Excel Workbook
When you start Excel, the program greets you with a brand-new workbook 
with the generic name “Book1” on the title bar. Workbook is just the Excel 
term for the files you create with the program. You can start working right 
away on the generic workbook or you can take advantage of one of Excel’s 
templates.

A template is a preformatted workbook designed for a specific purpose, 
such as budgeting, tracking inventories, or tracking purchase orders. 
Creating a workbook from a template is mighty convenient if you happen to 
find a template that suits your purposes, but in my experience, you almost 
always have to start from a generic, blank workbook because your data is 
your own. You need a workbook you create yourself, not one created from a 
template by someone else.
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443Getting Acquainted with Excel

 • Download a template from Office.com: Under Office.com Templates, 
either choose the type of template you want or make sure that your 
computer is connected to the Internet, enter a search term in the 
Search box, and click the Start Searching button (or press Enter). 
Choose a template and click the Download button to download it to 
your computer.

 • Use a template you created (or downloaded earlier from Microsoft): 
Click the My Templates icon. The New dialog box appears. Select a 
template and click OK. (Chapter 4 of this mini-book describes how 
to create your own template; after you create a template, its name 
appears in this dialog box.)

 • Select a recently used template: Click the Recent Templates icon and 
double-click a template name.

 ✦ Recycle another workbook: If you can use another workbook as the 
starting point for creating a new one, click the New from Existing icon. 
In the New from Existing Workbook dialog box, select the workbook and 
click the Create New button.

Book I, Chapter 1 explains how to save a workbook after you create it as well 
as how to open a workbook that you want to work on.

Getting Acquainted with Excel
If you’ve spent any time in an Office program, much of the Excel screen may 
look familiar to you. The buttons on the Home tab — the Bold and the Align 
buttons, for example — work the same in Excel as they do in Word. The Font 
and Font Size drop-down lists work the same as well. Any command in Excel 
that has to do with formatting text and numbers works the same in Excel 
and Word.

As I mention earlier, an Excel file is a workbook. Each workbook comprises 
one or more worksheets. A worksheet, also known as a spreadsheet, is a table 
where you enter data and data labels. Figure 1-2 shows a worksheet with 
data about rainfall in different counties.

A worksheet works like an accountant’s ledger — only it’s much easier to 
use. Notice how the worksheet is divided by gridlines into columns (A, B, 
C, and so on) and rows (1, 2, 3, and so on). The rectangles where columns 
and rows intersect are cells, and each cell can hold one data item, a formula 
for calculating data, or nothing at all. At the bottom of the worksheet are 
tabs — Sheet1, Sheet2, and Sheet3 — for visiting the other worksheets in 
the workbook.
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445Entering Data in a Worksheet

 

Figure 1-3: 

A chart 

generated 

from the 

data in 

Figure 1-2.

 

Rows, columns, and cell addresses
Not that anyone except an Enron accountant needs all of them, but an Excel 
worksheet has numerous columns and over 1 million rows. The rows are 
numbered, and columns are labeled A to Z; then AA to AZ; then BA to BZ, 
and so on. The important thing to remember is that each cell has an address 
whose name comes from a column letter and a row number. The first cell in 
row 1 is A1, the second is B1, and so on. You need to enter cell addresses in 
formulas to tell Excel which numbers to compute.

To find a cell’s address, either make note of which column and row it lies 
in, or click the cell and glance at the Formula bar (refer to Figure 1-2). The 
left side of the Formula bar lists the address of the active cell, the cell that is 
selected in the worksheet. In Figure 1-2, cell F7 is the active cell.

Workbooks and worksheets
When you create a new Excel file, you open a workbook, a file with three 
worksheets in it. The worksheets are called Sheet1, Sheet2, and Sheet3 (you 
can change their names and add more worksheets). To get from worksheet 
to worksheet, click tabs along the bottom of the Excel window. Why three 
worksheets? Because you might need more than one worksheet for a single 
project. Think of a workbook as a stack of worksheets. Besides calculating 
the numbers in cells across the rows or down the columns of a worksheet, 
you can make calculations throughout a workbook by using numbers from 
different worksheets in a calculation.

Entering Data in a Worksheet
Entering data in a worksheet is an irksome activity. Fortunately, Excel offers 
a few shortcuts to take the sting out of it. These pages explain how to enter 
data in a worksheet, the different types of data, and how to enter text labels, 
numbers, dates, and times.



450 Quickly Entering Lists and Serial Data with the AutoFill Command

 ✦ Dates in formulas: To enter a date directly in a formula, enclose the date 
in quotation marks. (Make sure that the cell where the formula is 
entered has been given the Number format, not the Date format.) For 
example, the formula =TODAY()-“1/1/2010” calculates the number of 
days that have elapsed since January 1, 2010. Formulas are the subject 
of Chapter 3 of this mini-book.

Entering time values
Excel recognizes time values that you enter in the following ways:

h:mm AM/PM 3:31 AM

h:mm:ss AM/PM 3:31:45 PM

Here are some things to remember when entering time values:

 ✦ Use colons: Separate hours, minutes, and seconds with a colon (:).

 ✦ Time formats: To change to the h:mm:ss AM/PM time format, select the 
cells, go to the Home tab, open the Number Format drop-down list, and 
choose Time (refer to Figure 1-5). You can also change time formats by 
clicking the Number group button on the Home tab and selecting a time 
format on the Number tab of the Format Cells dialog box.

 ✦ AM or PM time designations: Unless you enter AM or PM with the time, 
Excel assumes that you’re operating on military time. For example, 3:30 
is considered 3:30 a.m.; 15:30 is 3:30 p.m. Don’t enter periods after the 
letters am or pm (don’t enter a.m. or p.m.).

 ✦ Current time: Press Ctrl+Shift+; (semicolon) to enter the current time.

 ✦ Times on the Formula bar: On the Formula bar, times are displayed in 
this format: hours:minutes:seconds, followed by the letters AM or PM. 
However, the time format used in cells is up to you.

Combining date and time values
You can combine dates and time values by entering the date, a blank space, 
and the time:

 ✦ 7/31/10 3:31 am

 ✦ 7-31-10 3:31:45 pm

Quickly Entering Lists and Serial Data 
with the AutoFill Command

Data that falls in the “serial” category — month names, days of the week, 
and consecutive numbers and dates, for example — can be entered quickly 
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453Formatting Numbers, Dates, and Time Values

  The AutoFill Options button appears after you enter the serial data. Click it 
and choose an option if you want to copy cells or fill the cells without carry-
ing along their formats.

 

To enter the same number or text in several empty cells, drag over the cells 
to select them or select each cell by holding down the Ctrl key as you click. 
Then type a number or some text and press Ctrl+Enter.

Formatting Numbers, Dates, and Time Values
When you enter a number that Excel recognizes as belonging to one of its 
formats, Excel assigns the number format automatically. Enter 45%, for 
example, and Excel assigns the Percentage Style format. Enter $4.25, and 
Excel assigns the Currency Style format. Besides assigning formats by hand, 
however, you can assign them to cells from the get-go and spare yourself the 
trouble of entering dollar signs, commas, percent signs, and other extrane-
ous punctuation. All you have to do is enter the raw numbers. Excel does the 
window dressing for you.

Excel offers five number-formatting buttons on the Home tab — Accounting 
Number Format, Percent Style, Comma Style, Increase Decimal, and 
Decrease Decimal. Select cells with numbers in them and click one of these 
buttons to change how numbers are formatted:

  ✦ Accounting Number Format: Places a dollar sign before the number and 
gives it two decimal places. You can open the drop-down list on this 
button and choose a currency symbol apart from the dollar sign.

  ✦ Percent Style: Places a percent sign after the number and converts the 
number to a percentage.

  ✦ Comma Style: Places commas in the number.

  ✦ Increase Decimal: Increases the number of decimal places by one.

  ✦ Decrease Decimal: Decreases the number of decimal places by one.

To choose among many formats and to format dates and time values as 
well as numbers, go to the Home tab, click the Number group button, and 
make selections on the Number tab of the Format Cells dialog box. Figure 1-7 
shows this dialog box. Choose a category and select options to describe how 
you want numbers or text to appear.

  To strip formats from the data in cells, select the cells, go to the Home tab, 
click the Clear button, and choose Clear Formats.



454 Conditional Formats for Calling Attention to Data

 

Figure 1-7: 

The Number 

category of 

the Format 

Cells dialog 

box.

 

 

Entering ZIP Codes can be problematic because Excel strips the initial zero 
from the number if it begins with a zero. To get around that problem, visit 
the Number tab of the Format Cells dialog box (see Figure 1-7), choose 
Special in the Category list, and select a ZIP Code option.

Conditional Formats for Calling Attention to Data
A conditional format is one that applies when data meets certain conditions. 
To call attention to numbers greater than 10,000, for example, you can tell 
Excel to highlight those numbers automatically. To highlight negative num-
bers, you can tell Excel to display them in bright red. Conditional formats 
help you analyze and understand data better.

Select the cells that are candidates for conditional formatting and follow 
these steps to tell Excel when and how to format the cells:

  1. On the Home tab, click the Conditional Formatting button (you may 
have to click the Styles button first, depending on the size of your 
screen).

 2. Choose Highlight Cells Rules or Top/Bottom Rules on the drop-down 
list.

  You see a submenu with choices about establishing the rule for whether 
values in the cells are highlighted or otherwise made more prominent:
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455Establishing Data-Validation Rules

 • Highlight Cells Rules: These rules are for calling attention to data if 
it falls in a numerical or date range, or it’s greater or lesser than a 
specific value. For example, you can highlight cells that are greater 
than 400.

 • Top/Bottom Rules: These rules are for calling attention to data if it 
falls within a percentage range relative to all the cells you selected. 
For example, you can highlight cells with data that falls in the bottom 
10 percent range.

 3. Choose an option on the submenu.

  You see a dialog box similar to the ones in Figure 1-8.

 

Figure 1-8: 

Establishing 

a condition 

format for 

data.

 

 4. On the left side of the dialog box, establish the rule for flagging data.

 5. On the With drop-down list, choose how you want to call attention to 
the data.

  For example, you can display the data in red or yellow. You can choose 
Custom Format on the drop-down list to open the Format Cells dialog 
box and choose a font style or color for the text.

 6. Click OK.

To remove conditional formats, select the cells with the formats, go to the 
Home tab, click the Conditional Formatting button, and choose Clear Rules➪

Clear Rules from Selected Cells.

Establishing Data-Validation Rules
By nature, people are prone to enter data incorrectly because the task of 
entering data is so dull. This is why data-validation rules are invaluable. A 
data-validation rule is a rule concerning what kind of data can be entered in a 
cell. When you select a cell that has been given a rule, an input message tells 
you what to enter, as shown in Figure 1-9. And if you enter the data incor-
rectly, an error alert tells you as much, also shown in Figure 1-9.



Chapter 2: Refining 
Your Worksheet

In This Chapter
✓ Changing worksheet data

✓ Going here and there in a worksheet

✓ Freezing and splitting columns and rows to make data entry easier

✓ Documenting a worksheet with comments

✓ Selecting cells

✓ Copying and moving data

✓ Moving among, deleting, and renaming worksheets

✓ Hiding and protecting worksheets so that they can’t be altered

This chapter delves into the workaday world of worksheets (say that 
three times fast). It explains how to edit worksheet data and move 

quickly here and there in a worksheet. You also discover a couple of tech-
niques for entering data quickly, how to select cells, and how to copy and 
move data in cells. This chapter describes how to move, delete, and rename 
worksheets, as well as protect them from being edited or altered.

Editing Worksheet Data
Not everyone enters data correctly the first time. To edit data you entered 
in a cell, do one of the following:

 ✦ Double-click the cell. Doing so places the cursor squarely in the cell, 
where you can start deleting or entering numbers and text.

 ✦ Click the cell and press F2. This technique also lands the cursor in the 
cell.

 ✦ Click the cell you want to edit. With this technique, you edit the data 
on the Formula bar.

 

If nothing happens when you double-click, or if pressing F2 lands the cursor 
in the Formula bar, not a cell, somebody has been fooling with the Options 
settings. On the File tab, choose Options, select the Advanced category in 
the Excel Options dialog box, and click the Allow Editing Directly in Cells 
check box.



460 Moving Around in a Worksheet

Moving Around in a Worksheet
Going from place to place gets progressively more difficult as a worksheet 
gets larger. Luckily for you, Excel offers keyboard shortcuts for jumping 
around. Table 2-1 describes these keyboard shortcuts.

Table 2-1 Keyboard Shortcuts for Getting Around in Worksheets

Press. . . To Move the Selection. . .

Home To column A

Ctrl+Home To cell A1, the first cell in the worksheet

Ctrl+End To the last cell in the last row with data in it

←, →, ↑, ↓ To the next cell

Ctrl+←, →, ↑, ↓ In one direction toward the nearest cell with data in it 
or to the first or last cell in the column or row

PgUp or PgDn Up or down one screen’s worth of rows

Ctrl+PgUp or Ctrl+PgDn Backward or forward through the workbook, from 
worksheet to worksheet

In addition to pressing keys, you can use these techniques to get from place 
to place in a worksheet:

 ✦ Scroll bars: Use the vertical and horizontal scroll bars to move to differ-
ent areas. Drag the scroll box to cover long distances. To cover long dis-
tances very quickly, hold down the Shift key as you drag the scroll box 
on the vertical scroll bar.

 ✦ Scroll wheel on the mouse: If your mouse is equipped with a scroll 
wheel, turn the wheel to quickly scroll up and down.

 ✦ Name box: Enter a cell address in the Name box and press Enter to go to 
the cell. The Name box is found to the left of the Formula bar.

  ✦ The Go To command: On the Home tab, click the Find & Select button, 
and choose Go To on the drop-down list (or press Ctrl+G or F5). You see 
the Go To dialog box. Enter a cell address in the Reference box and click 
OK. Cell addresses you’ve already visited with the Go To command are 
already listed in the dialog box. Click the Special button to open the Go To 
Special dialog box and visit a formula, comment, or other esoteric item.

 ✦ The Find command: On the Home tab, click the Find & Select button, 
and choose Find on the drop-down list (or press Ctrl+F). Enter the data 
you seek in the Find What box and click the Find Next button. Click the 
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461Getting a Better Look at the Worksheet

Find All button to find all instances of the item you’re looking for. A list 
of the items appears at the bottom of the dialog box; click an item to 
go to it.

 

To scroll to the active cell if you no longer see it on-screen, press 
Ctrl+Backspace.

Getting a Better Look at the Worksheet
Especially when you’re entering data, it pays to get a good look at the work-
sheet. You need to know which column and row you’re entering data in. 
These pages explain techniques for changing your view of a worksheet so 
that you always know where you are. Read on to discover how to freeze, 
split, and hide columns and rows. (On the subject of changing views, Book 
I, Chapter 3 explains an essential technique for changing views: zooming in 
and zooming out.)

Freezing and splitting columns and rows
Sometimes your adventures in a worksheet take you to a faraway cell 
address, such as X31 or C39. Out there in the wilderness, it’s hard to tell 
where to enter data because you can’t see the data labels in the first column 
or first row that tell you where to enter data on the worksheet.

To see one part of a worksheet no matter how far you stray from it, you can 
split the worksheet or freeze columns and rows on-screen. In Figure 2-1, I 
split the worksheet so that column A (Property) always appears on-screen, 
no matter how far I scroll to the right; similarly, row 1 (Property, Rent, 
Management Fees, and so on) also appears at the top of the worksheet no 
matter how far I scroll down. Notice how the row numbers and column let-
ters are interrupted in Figure 2-1. Because I split the screen, I always know 
what data to enter in a cell because I can clearly see property names in the 
first column and the column headings along the top of the worksheet.

Freezing columns or rows on a worksheet works much like splitting except 
that lines instead of gray bars appear on-screen to show which columns and 
rows are frozen, and you can’t adjust where the split occurs by dragging the 
boundary where the worksheet is split.

 

Splitting the worksheet is superior to freezing columns or rows because, for 
one, you can drag the split lines to new locations when you split the work-
sheet, and moreover, you can remove a horizontal or vertical split simply by 
double-clicking it. However, if your goal is simply to freeze the topmost row 
or leftmost column in your worksheet, use a Freeze Panes command because 
all you have to do is go to the View tab, click the Freeze Panes button, and 
choose Freeze Top Row or Freeze First Column.



464 Comments for Documenting Your Worksheet

  ✦ Hiding columns or rows: Drag over the column letters or row numbers of 
the columns or rows that you want to hide. Dragging this way selects 
entire columns or rows. Then go to the Home tab, click the Format button, 
choose Hide & Unhide, and choose Hide Columns or Hide Rows.

 ✦ Unhiding columns and rows: Select columns to the right and left of the 
hidden columns, or select rows above and below the hidden rows. To 
select columns or rows, drag over their letters or numbers. Then go 
to the Home tab, click the Format button, choose Hide & Unhide, and 
choose Unhide Columns or Unhide Rows.

 

It’s easy to forget where you hid columns or rows. To make sure that all col-
umns and rows in your worksheet are displayed, click the Select All button 
(or press Ctrl+A) to select your entire worksheet. Then go to the Home tab, 
click the Format button and choose Hide & Unhide➪Unhide Columns; click 
the Format button again and choose Hide & Unhide➪Unhide Rows.

Comments for Documenting Your Worksheet
It may happen that you return to your worksheet days or months from now 
and discover to your dismay that you don’t know why certain numbers or 
formulas are there. For that matter, someone else may inherit your work-
sheet and be mystified as to what the heck is going on. To take the mystery 
out of a worksheet, document it by entering comments here and there.

A comment is a note that describes part of a worksheet. Each comment is 
connected to a cell. You can tell where a comment is because a small red tri-
angle appears in the upper-right corner of cells that have been commented 
on. Move the pointer over one of these triangles and you see the pop-up 
box, a comment, and the name of the person who entered the comment, as 
shown in Figure 2-2. Click the Show All Comments button on the Review tab 
to see every comment in a worksheet.

Here’s everything a mere mortal needs to know about comments:

  ✦ Entering a comment: Click the cell that deserves the comment, go to the 
Review tab, and click the New Comment button. Enter your comment in 
the pop-up box. Click in a different cell when you finish entering your 
comment.

 ✦ Reading a comment: Move the pointer over the small red triangle and 
read the comment in the pop-up box (refer to Figure 2-2).

 ✦ Finding comments: On the Review tab, click the Previous or Next button 
to go from comment to comment.

  ✦ Editing a comment: On the Review tab, select the cell with the com-
ment, click the Edit Comment button, and edit the comment in the 
pop-up box. You can also right-click the cell and choose Edit Comment.
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465Selecting Cells in a Worksheet

 

Figure 2-2: 

Comments 

explain 

what’s 

what in a 

worksheet.

 

  ✦ Deleting comments: On the Review tab, click a cell with a comment, 
and then click the Delete button, or right-click the cell and choose 
Delete Comment. To delete several comments, select them by 
Ctrl+clicking and then click the Delete button.

 ✦ Deleting all comments in a worksheet: Select all comments and then, 
on the Review tab, click the Delete button. You can select all comments 
by clicking the Find & Select button on the Home tab, choosing Go To, 
and in the Go To dialog box, clicking the Special button and choosing 
Comments in the Go To Special dialog box.

 

If your name doesn’t appear in the pop-up box after you enter a comment 
and you want it to appear there, go to the File tab, choose Options, select 
the General category in the Excel Options dialog box, and enter your name in 
the User Name text box.

You can print the comments in a worksheet. On the Page Layout tab, click 
the Page Setup group button, and on the Sheet tab of the Page Setup dialog 
box, open the Comments drop-down list and choose At End of Sheet or As 
Displayed on Sheet.

Selecting Cells in a Worksheet
To format, copy, move, delete, and format numbers and words in a work-
sheet, you have to select the cells in which the numbers and words are 
found. Here are ways to select cells and the data inside them:

 ✦ A block of cells: Drag diagonally across the worksheet from one corner 
of the block of cells to the opposite corner. You can also click in one 
corner and Shift+click the opposite corner.



466 Deleting, Copying, and Moving Data

 ✦ Adjacent cells in a row or column: Drag across the cells.

 ✦ Cells in various places: While holding down the Ctrl key, click different 
cells.

 ✦ A row or rows: Click a row number to select an entire row. Click and 
drag down the row numbers to select several adjacent rows.

 ✦ A column or columns: Click a column letter to select an entire column. 
Click and drag across letters to select adjacent columns.

  ✦ Entire worksheet: Click the Select All button, the square to the left of 
the column letters and above the row numbers; press Ctrl+A; or press 
Ctrl+Shift+Spacebar.

 

Press Ctrl+Spacebar to select the column that the active cell is in; press 
Shift+Spacebar to select the row where the active cell is.

You can enter the same data item in several different cells by selecting cells 
and then entering the data in one cell and pressing Ctrl+Enter. This tech-
nique comes in very handy, for example, when you want to enter a place-
holder zero (0) in several different cells.

Deleting, Copying, and Moving Data
In the course of putting together a worksheet, it is sometimes necessary to 
delete, copy, and move cell contents. Here are instructions for doing these 
chores:

  ✦ Deleting cell contents: Select the cells and then press the Delete key; on 
the Home tab, click the Clear button and choose Clear Contents; or 
right-click and choose Clear Contents. (Avoid the Delete button on the 
Home tab for deleting cell contents. Clicking that button deletes cells as 
well as their contents.)

 ✦ Copying and moving cell contents: Select the cells and use one of these 
techniques:

  • Cut or Copy and Paste commands: When you paste the data, click 
where you want the first cell of the block of cells you’re copying or 
moving to go. (Book I, Chapter 2 explains copying and moving data in 
detail.) Be careful not to overwrite cells with data in them when you 
copy or move data. After you paste data, you see the Paste Options 
button. Click this button and choose an option from the drop-down 
list to format the data in different ways.

 • Drag and drop: Move the pointer to the edge of the cell block, click 
when you see the four-headed arrow, and start dragging. Hold down 
the Ctrl key to copy the data.



Book V

Chapter 2

R
e

fin
in

g
 Y

o
u

r 
W

o
rk

sh
e

e
t

467Handling the Worksheets in a Workbook

Handling the Worksheets in a Workbook
As a glance at the bottom of the worksheet tells you, each workbook comes 
with three worksheets named (not very creatively) Sheet1, Sheet2, and 
Sheet3. Follow these instructions to move among, add, delete, rename, and 
change the order of worksheets:

 ✦ Moving among worksheets: To go from one worksheet to another, click 
a worksheet tab along the bottom of the screen. If you can’t see a tab, 
click one of the scroll arrows to the left of the worksheet tabs.

 ✦ Renaming a worksheet: Right-click the worksheet tab, choose Rename 
on the shortcut menu, type a new name, and press Enter. You can also 
go to the Home tab, click the Format button, choose Rename Sheet on 
the drop-down list, and enter a new name. Spaces are allowed in names, 
and names can be 31 characters long. Brackets ([]) are allowed in 
names, but you can’t use these symbols: / \ : ? and *.

 ✦ Selecting worksheets: Click the worksheet’s tab to select it. To select 
several worksheets, Ctrl+click their tabs or click the first tab and then 
Shift+click the last tab in the set. To select all the worksheets, right-click 
a tab and choose Select All Sheets on the shortcut menu.

 ✦ Rearranging worksheets: Drag the worksheet tab to a new location. As 
you drag, a tiny black arrow and a page icon appear to show you where 
the worksheet will land after you release the mouse button. You can also 
select a sheet, go to the Home tab, click the Format button, and choose 
Move or Copy Sheet on the drop-down list. The Move or Copy dialog box 
appears, as shown in Figure 2-3. Select the sheet in the Before Sheet list 
where you want the worksheet to go and click OK.

  ✦ Inserting a new worksheet: Click the Insert Sheet button (you can find it 
to the right of the worksheet tabs); press Shift+F11; or on the Home tab, 
open the drop-down list on the Insert button and choose Insert Sheet.

 

Figure 2-3: 

Besides 

dragging 

it, you can 

move a 

worksheet 
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box.

 



468 Keeping Others from Tampering with Worksheets

  ✦ Deleting a worksheet: Select the sheet, and on the Home tab, open the 
drop-down list on the Delete button and choose Delete Sheet. You can 
also right-click a worksheet tab and choose Delete. Be careful because 
you can’t restore your deleted worksheet by pressing the Undo button.

 ✦ Copying a worksheet: Select the sheet, hold down the Ctrl key, and drag 
the worksheet tab to a new location.

 ✦ Color-coding a worksheet: Right-click a worksheet tab and choose Tab 
Color. Then select a color in the submenu, or choose More Colors and 
select a color in the Colors dialog box. You can also select a worksheet 
tab, go to the Home tab, click the Format button, choose Tab Color on 
the drop-down list, and choose a color on the submenu.

 

You can change the size of columns or apply numeric formats to the same 
addresses in different worksheets by selecting all the sheets first and then 
formatting one worksheet. The formats apply to all the worksheets that you 
select. Being able to format several different worksheets simultaneously 
comes in handy, for example, when your workbook tracks monthly data and 
each worksheet pertains to one month. Another way to handle worksheets 
with similar data is to create the first worksheet and copy it to the second, 
third, and fourth worksheets with the Copy and Paste commands.

Keeping Others from Tampering with Worksheets
People with savvy and foresight sometimes set up workbooks so that one 
worksheet holds raw data and the other worksheets hold formulas that cal-
culate the raw data. This technique prevents others from tampering with the 
raw data. Furthermore, if the worksheet with raw data is hidden, the chance 
it will be tampered with is lower; and if the worksheet is protected, no one 
can tamper with it unless they have a password. These pages explain how to 
hide a worksheet so that others are less likely to find it and how to protect a 
worksheet from being edited.

Hiding a worksheet
Follow these instructions to hide and unhide worksheets:

  ✦ Hiding a worksheet: Select the worksheet you want to hide, go to the 
View tab, and click the Hide button. You can also right-click the work-
sheet’s tab and choose Hide on the shortcut menu. And you can also dis-
play the worksheet, go to the Home tab, click the Format button, and 
choose Hide &Unhide➪Hide Sheet.

  ✦ Unhiding a worksheet: On the View tab, click the Unhide button, select 
the name of the worksheet you want to unhide in the Unhide dialog box, 
and click OK. To open the Unhide dialog box, you can also right-click 
any worksheet tab and choose Unhide; or go to the Home tab, click the 
Format button, and choose Hide & Unhide➪Unhide Sheet.



Chapter 3: Formulas and Functions 
for Crunching Numbers

In This Chapter
✓ Constructing a formula

✓ Using cell ranges in formulas

✓ Naming cell ranges

✓ Referring to cells in other worksheets

✓ Copying formulas to other columns and rows

✓ Preventing errors in formulas

✓ Using functions in formulas

Formulas are where it’s at as far as Excel is concerned. After you know 
how to construct formulas, and constructing them is pretty easy, you 

can put Excel to work. You can make the numbers speak to you. You can 
turn a bunch of unruly numbers into meaningful figures and statistics.

This chapter explains what a formula is, how to enter a formula, and how to 
enter a formula quickly. You also discover how to copy formulas from cell 
to cell and how to keep formula errors from creeping into your workbooks. 
Finally, this chapter explains how to make use of the hundred or so func-
tions that Excel offers.

How Formulas Work
A formula, you may recall from the sleepy hours you spent in math class, 
is a way to calculate numbers. For example, 2+3=5 is a formula. When you 
enter a formula in a cell, Excel computes the formula and displays its results 
in the cell. Click in cell A3 and enter =2+3, for example, and Excel displays 
the number 5 in cell A3.

Referring to cells in formulas
As well as numbers, Excel formulas can refer to the contents of different 
cells. When a formula refers to a cell, the number in the cell is used to com-
pute the formula. In Figure 3-1, for example, cell A1 contains the number 2; 
cell A2 contains the number 3; and cell A3 contains the formula =A1+A2. As 
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Another way to compute a formula is to make use of a function. As “Working 
with Functions” explains later in this chapter, a function is a built-in formula 
that comes with Excel. SUM, for example, adds the numbers in cells. AVG 
finds the average of different numbers.

The Basics of Entering a Formula
No matter what kind of formula you enter, no matter how complex the for-
mula is, follow these basic steps to enter it:

 1. Click the cell where you want to enter the formula.

 2. Click in the Formula bar if you want to enter the data there rather 
than in the cell.

 3. Enter the equals sign (=).

  You must be sure to enter the equals sign before you enter a formula. 
Without it, Excel thinks you’re entering text or a number, not a formula.

 4. Enter the formula.

  For example, enter =B1*.06. Make sure that you enter all cell addresses 
correctly. By the way, you can enter lowercase letters in cell references. 
Excel changes them to uppercase after you finish entering the formula. 
The next section in this chapter explains how to quickly enter cell 
addresses in formulas.

When a formula includes more than one opera-
tor, the order in which the operators appear in 
the formula matters a lot. Consider this formula:

=2+3*4

Does this formula result in 14 (2+[3*4]) or 20 
([2+3]*4)? The answer is 14 because Excel 
performs multiplication before addition in 
formulas. In other words, multiplication 
takes precedence over addition. The order in 
which calculations are made in a formula that 
includes different operators is called the order 

of precedence. Be sure to remember the order 
of precedence when you construct complex 
formulas with more than one operator:

 1. Percent (%)

 2. Exponentiation (^)

 3. Multiplication (*) and division (/); leftmost 
operations are calculated first

 4. Addition (+) and subtraction (-); leftmost 
operations are calculated first

 5. Concatenation (&)

 6. Comparison (<, <=, >,>=, and <>)

To get around the order of precedence prob-
lem, enclose parts of formulas in parentheses. 
Operations in parentheses are calculated 
before all other parts of a formula. For example, 
the formula =2+3*4 equals 20 when it is written 
this way: =(2+3)*4.

The order of precedence
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477Speed Techniques for Entering Formulas

  5. Press Enter or click the Enter button (the check mark on the 
Formula bar).

  The result of the formula appears in the cell.

Speed Techniques for Entering Formulas
Entering formulas and making sure that all cell references are correct is a 
tedious activity, but fortunately for you, Excel offers a few techniques to 
make entering formulas easier. Read on to find out how ranges make entering 
cell references easier and how you can enter cell references in formulas by 
pointing and clicking. You also find instructions here for copying formulas.

Clicking cells to enter cell references
The hardest part about entering a formula is entering the cell references cor-
rectly. You have to squint to see which row and column the cell you want 
to refer to is in. You have to carefully type the right column letter and row 
number. However, instead of typing a cell reference, you can click the cell 
you want to refer to in a formula.

In the course of entering a formula, simply click the cell on your worksheet 
that you want to reference. As shown in Figure 3-5, shimmering marquee 
lights appear around the cell that you clicked so that you can clearly see 
which cell you’re referring to. The cell’s reference address, meanwhile, 
appears in the Formula bar. In Figure 3-5, I clicked cell F3 instead of entering 
its reference address on the Formula bar. The reference F3 appears on the 
Formula bar, and the marquee lights appear around cell F3.

Get in the habit of pointing and clicking cells to enter cell references in for-
mulas. Clicking cells is easier than typing cell addresses, and the cell refer-
ences are entered more accurately.

 

Figure 3-5: 

Clicking to 

enter a cell 

reference.

 

Click a cell to enter its cell reference address in a formula



482 Copying Formulas from Cell to Cell

 The only thing odd about constructing formulas across worksheets are the 
cell references. As a glance at the Formula bar tells you, cell addresses in 
cross-worksheet formulas list the sheet name and an exclamation point (!) as 
well as the cell address itself. For example, this formula in Worksheet 1 adds 
the number in cell A4 to the numbers in cells D5 and E5 in Worksheet 2:

=A4+Sheet2!D5+Sheet2!E5

This formula in Sheet 2 multiplies the number in cell E18 by the number in 
cell C15 in Worksheet 1:

=E18*Sheet1!C15

This formula in Worksheet 2 finds the average of the numbers in the cell 
range C7:F7 in Worksheet 1:

=AVERAGE(Sheet1!C7:F7)

Copying Formulas from Cell to Cell
Often in worksheets, the same formula but with different cell references is 
used across a row or down a column. For example, in the worksheet shown 
in Figure 3-9, column F totals the rainfall figures in rows 7 through 11. To 
enter formulas for totaling the rainfall figures in column F, you could labori-
ously enter formulas in cells F7, F8, F9, F10, and F11. But a faster way is to 
enter the formula once in cell F7 and then copy the formula in F7 down the 
column to cells F8, F9, F10, and F11.

 When you copy a formula to a new cell, Excel adjusts the cell references in 
the formula so that the formula works in the cells to which it has been 
copied. Astounding! Opportunities to copy formulas abound on most work-
sheets. And copying formulas is the fastest and safest way to enter formulas 
in a worksheet.

Follow these steps to copy a formula:

 1. Select the cell with the formula you want to copy down a column or 
across a row.

 2. Drag the AutoFill handle across the cells to which you want to copy 
the formula.

  This is the same AutoFill handle you drag to enter serial data (see 
Chapter 1 of this mini-book about entering lists and serial data with the 
AutoFill command). The AutoFill handle is the small black square in the 
lower-right corner of the cell. When you move the mouse pointer over it, 
it changes to a black cross. Figure 3-9 shows a formula being copied.
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483Detecting and Correcting Errors in Formulas

 3. Release the mouse button.

  If I were you, I would click in the cells to which you copied the formula 
and glance at the Formula bar to make sure that the formula was copied 
correctly. I’d bet you it was.

You can also copy formulas with the Copy and Paste commands. Just make 
sure that cell references refer correctly to the surrounding cells.

 

Figure 3-9: 

Copying a 

formula.

 

Drag the AutoFill handle

Detecting and Correcting Errors in Formulas
It happens. Everyone makes an error from time to time when entering formu-
las in cells. Especially in a worksheet in which formula results are calculated 
into other formulas, a single error in one formula can spread like a virus and 
cause miscalculations throughout a worksheet. To prevent that from hap-
pening, Excel offers several ways to correct errors in formulas. You can cor-
rect them one at a time, run the error checker, and trace cell references, as 
the following pages explain.

  By the way, if you want to see formulas in cells rather than formula results, 
go to the Formulas tab and click the Show Formulas button (or press Ctrl+’). 
Sometimes seeing formulas this way helps to detect formula errors.
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  ✦ Tracing precedents: Select a cell with a formula in it and trace the for-
mula’s precedents to find out which cells are computed to produce the 
results of the formula. Trace precedents when you want to find out 
where a formula gets its computation data. Cell tracer arrows point from 
the referenced cells to the cell with the formula results in it.

  To trace precedents, go to the Formulas tab and click the Trace 
Precedents button (you may have to click the Formula Auditing button 
first, depending on the size of your screen).

  ✦ Tracing dependents: Select a cell and trace its dependents to find out 
which cells contain formulas that use data from the cell you selected. 
Cell tracer arrows point from the cell you selected to cells with formula 
results in them. Trace dependents when you want to find out how the 
data in a cell contributes to formulas elsewhere in the worksheet. The 
cell you select can contain a constant value or a formula in its own right 
(and contribute its results to another formula).

  To trace dependents, go to the Formulas tab and click the Trace 
Dependents button (you may have to click the Formula Auditing button 
first, depending on the size of your screen).

  To remove the cell tracer arrows from a worksheet, go to the Formulas tab 
and click the Remove Arrows button. You can open the drop-down list on 
this button and choose Remove Precedent Arrows or Remove Dependent 
Arrows to remove only cell-precedent or cell-dependent tracer arrows.

Working with Functions
A function is a canned formula that comes with Excel. Excel offers hundreds 
of functions, some of which are very obscure and fit only for use by rocket 
scientists or securities analysts. Other functions are very practical. For 
example, you can use the SUM function to quickly total the numbers in a 
range of cells. Instead of entering =C2+C3+C4+C5 on the Formula bar, you 
can enter =SUM(C2:C5), which tells Excel to total the numbers in cell C2, C3, 
C4, and C5. To obtain the product of the number in cell G4 and .06, you can 
use the PRODUCT function and enter =PRODUCT(G4,.06) on the Formula bar.

  Table 3-3 lists the most common functions. To get an idea of the numerous 
functions that Excel offers, go to the Formulas tab and click the Insert 
Function button. You see the Insert Function dialog box shown in Figure 
3-12. (Later in this chapter, I show you how you this dialog box helps you 
use functions in formulas.) Choose a function category in the dialog box, 



Chapter 4: Making a Worksheet 
Easier to Read and Understand

In This Chapter
✓ Aligning numbers and text

✓ Changing column and row sizes

✓ Applying cell styles to data in cells

✓ Splashing color on a worksheet

✓ Drawing borders between cells and titles

✓ Making worksheets fit well on the page

✓ Preparing a worksheet before you print it

This chapter explains how to dress a worksheet in its Sunday best in case 
you want to print and present it to others. It explains how to align num-

bers and text, insert rows and columns, as well as change the size of rows 
and columns. You find out how to decorate a worksheet with colors and 
borders, as well as create and apply styles to make formatting tasks go more 
quickly. Finally, this chapter describes everything you need to know before 
you print a worksheet, including how to make it fit on one page and repeat 
row labels and column names on all pages.

Laying Out a Worksheet
Especially if you intend to print your worksheet, you may as well dress it 
in its Sunday best. And you can do a number of things to make worksheets 
easier to read and understand. You can change character fonts. You can 
draw borders around or shade important cells. You can also format the 
numbers so that readers know, for example, whether they’re staring at 
dollar figures or percentages. This part of Chapter 4 is dedicated to the 
proposition that a worksheet doesn’t have to look drab and solemn.

Aligning numbers and text in columns and rows
To start with, numbers in worksheets are right-aligned in cells, and text is 
left-aligned. Numbers and text sit squarely on the bottom of cells. You can, 
however, change the way that data is aligned. For example, you can make 
data float at the top of cells rather than rest at the bottom, and you can 
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 ✦ One at a time: Move the mouse pointer onto the boundary between 
column letters, and when the pointer changes to a cross, drag the 
border between the columns. A pop-up box tells you what size the 
column is.

  ✦ Several at a time: Select several columns and drag the boundary 
between one of the columns; all columns adjust to the same width. You 
can also go to the Home tab, click the Format button, choose Column 
Width, and enter a measurement in the Column Width dialog box.

 

✦ As wide as their entries: To make columns as wide as their widest 
entries, select the columns, go to the Home tab, click the Format button, 
and choose AutoFit Column Width on the drop-down list. You can also 
double-click the right border of a column letter. By “auto-fitting” col-
umns, you can be certain that the data in each cell in a column appears 
on-screen.

To change the 8.43-character standard width for columns in a worksheet, go 
to the Home tab, click the Format button, choose Default Width on the drop-
down list, and enter a new measurement in the Standard Width dialog box.

Decorating a Worksheet with Borders and Colors
The job of gridlines is simply to help you line up numbers and letters in 
cells. By default, gridlines aren’t printed, and because gridlines aren’t 
printed, drawing borders on worksheets is absolutely necessary if you 
intend to print your worksheet. Use borders to steer the reader’s eye to the 
most important parts of your worksheet — the totals, column labels, and 
heading labels. You can also decorate worksheets with colors. This part of 
the chapter explains how to put borders and colors on worksheets.

Cell styles for quickly formatting a worksheet
A style is a collection of formats — boldface text, a background color, or a 
border around cells — that can be applied all at one time to cells without 
having to visit a bunch of different dialog boxes or give a bunch of different 
commands. Styles save time. If you find yourself choosing the same format-
ting commands time and time again, consider creating a style. That way, 
you can apply all the formats simultaneously and go to lunch earlier. Excel 
comes with many built-in styles, and you can create styles of your own, as 
the following pages explain.

Applying a built-in cell style
By way of the Cell Styles gallery, you can choose from any number of attrac-
tive styles for cells in a worksheet. Excel offers styles for titles and head-
ings, styles for calling attention to what kind of data is in cells, and styles to 
accent cells. Follow these steps to reformat cells by choosing a cell style:
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503Getting Ready to Print a Worksheet

Getting Ready to Print a Worksheet
Printing a worksheet isn’t simply a matter of giving the Print command. A 
worksheet is a vast piece of computerized sprawl. Most worksheets don’t 
fit neatly on a single page. If you simply click the Print button to print your 
worksheet, you wind up with page breaks in unexpected places, both on the 
right side of the page and the bottom. Read on to discover how to set up a 
worksheet so that the people you hand it to can read and understand it.

Making a worksheet fit on a page
Unless you tell it otherwise, Excel prints everything from cell A1 to the last 
cell with data in it in the southeast corner of the worksheet. Usually, it isn’t 
necessary to print all those cells because some of them are blank. And print-
ing an entire worksheet often means breaking the page up in all kinds of awk-
ward places. To keep that from happening, following are some techniques 
for making a worksheet fit tidily on one or two pages.

  As you experiment with the techniques described here, switch occasionally 
to Page Layout view. In this view, you get a better idea of what your work-
sheet will look like when you print it. To switch to Page Layout view, click 
the Page Layout button on the status bar or View tab.

If you go to the trouble to lay out a very fine 
workbook, you may as well save it as a tem-
plate. That way, you (or your co-workers) can 
call upon your newfangled workbook next time 
you want to create a new Excel workbook. Any 
workbook that could be of use to someone else 
is a candidate for becoming a template.

Follow these steps to save a workbook as a 
template and be able to call upon its formats 
later on:

 1. On the File tab, choose Save As.

  You see the Save As dialog box.

 2. Enter a descriptive name for your template 
in the File Name text box.

 3. In the Save As Type drop-down list, 
choose Excel Template.

 4. Click the Save button.

 5. Back in your worksheet, delete the data 
that you don’t need when you create a file 
from your template and then click the Save 
button to save the template again.

To call upon the template you made to create a 
new Excel workbook, go to the File tab, choose 
New, click the My Templates icon in the 
Available Templates window, and in the New 
dialog box, select your template and click OK.

Saving your formats in a template



Chapter 5: Analyzing Data

In This Chapter
✓ Sorting information in a worksheet list

✓ Filtering a list to find the information you need

✓ Using the Goal Seek command to produce formula results

✓ Performing what-if analyses with data tables

This chapter offers a handful of tricks for analyzing the data that you so 
carefully and lovingly enter in a worksheet. Delve into this chapter to 

find out how to manage, sort, and filter worksheet lists. You also discover 
how the Goal Seek command can help you target values in different kinds of 
analysis, and how you can map out different scenarios with data by using 
one- and two-input data tables.

Managing Information in Lists
Although Excel is a spreadsheet program, many people use it to keep and 
maintain lists — address lists, product lists, employee lists, and inven-
tory lists, among other types of lists. These pages deal with all the differ-
ent things you can do with a worksheet list. They explain the difference 
between a conventional worksheet and a list, constructing a list, sorting a 
list, and filtering a list.

Constructing a list
To sort and filter data in a worksheet, your worksheet must be constructed 
like a list. Make sure that your worksheet has these characteristics:

 ✦ Column labels: Enter column labels along the top row, as shown in 
Figure 5-1. Excel needs these labels to identify and be able to filter the 
data in the rows below. Each label must have a different name. The row 
along the top of the worksheet where the column labels are is called the 
header row.

 ✦ No empty rows or columns: Sorry, but you can’t put an empty row or 
column in the middle of the worksheet list.

 ✦ No blank columns on the left: Don’t allow any empty columns to 
appear to the left of the list.
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Your next task is to open a drop-down list in the column that holds the crite-
ria you want to use to filter the list. For example, if you want to filter the list 
to items that cost more than $100, open the Cost column drop-down list; if 
you want to filter the list so that only the names of employees who make less 
than $30,000 annually appears, open the Salary drop-down list.

After you open the correct column drop-down list, tell Excel how you want 
to filter the list:

 ✦ Filter by exclusion: On the drop-down list, deselect the Select All check 
box and then select the check box next to each item you don’t want to 
filter out. For example, to filter an Address list to addresses in Boston, 
Chicago, and Miami, deselect the Select All check box and then select 
the check boxes next to Boston, Chicago, and Miami on the drop-down 
list. Your filter operation turns up only addresses in these three cities.

 ✦ Filter with criteria: On the drop-down list, choose Number Filters, 
and then choose a filter operation on the submenu (or simply choose 
Custom Filter). You see the Custom AutoFilter dialog box.

  Choose an operator (equals, is greater than, or another) from the drop-
down list, and either enter or choose a target criterion from the list on 
the right side of the dialog box. You can search by more than one crite-
rion. Select the And option button if a row must meet both criteria to be 
selected, or select the Or option button if a row can meet either crite-
rion to be selected.

Click the OK button on the column’s drop-down list or the Custom AutoFilter 
dialog box to filter your list.

  To see all the data in the list again — to unfilter the list — click the Clear 
button on the Data tab.

Forecasting with the Goal Seek Command
In a conventional formula, you provide the raw data, and Excel produces the 
results. With the Goal Seek command, you declare what you want the results 
to be, and Excel tells you the raw data you need to produce those results. 
The Goal Seek command is useful in analyses when you want the outcome to 
be a certain way and you need to know which raw numbers will produce the 
outcome that you want.

Figure 5-4 shows a worksheet designed to find out the monthly payment 
on a mortgage. With the PMT function, the worksheet determines that the 
monthly payment on a $250,000 loan with an interest rate of 6.5 percent 
and to be paid over a 30-year period is $1,580.17. Suppose, however, that 
the person who calculated this monthly payment determined that he or she 



514 Performing What-If Analyses with Data Tables

 5. Click OK.

  The Goal Seek Status dialog box appears (refer to Figure 5-4). It lists the 
target value that you entered in Step 3.

 6. Click OK.

  On your worksheet, the cell with the argument you wanted to alter now 
shows the target you’re seeking. In the case of the example worksheet in 
Figure 5-4, you can borrow $316,422 at 6.5 percent, not $250,000, by rais-
ing your monthly mortgage payments from $1,580.17 to $2,000.

Performing What-If Analyses with Data Tables
For something a little more sophisticated than the Goal Seek command 
(which I describe in the preceding section), try performing what-if analyses 
with data tables. With this technique, you change the data in input cells and 
observe what effect changing the data has on the results of a formula. The 
difference between the Goal Seek command and a data table is that, with a 
data table, you can experiment simultaneously with many different input 
cells and in so doing experiment with many different scenarios.

Using a one-input table for analysis
In a one-input table, you find out what the different results of a formula would 
be if you change one input cell in the formula. In Figure 5-5, that input cell is 
the interest rate on a loan. The purpose of this data table is to find out how 
monthly payments on a $250,000, 30-year mortgage are different, given differ-
ent interest rates. The interest rate in cell B4 is the input cell.

Follow these steps to create a one-input table:

 1. On your worksheet, enter values that you want to substitute for the 
value in the input cell.

  To make the input table work, you have to enter the substitute values in 
the right location:

 • In a column: Enter the values in the column starting one cell below 
and one cell to the left of the cell where the formula is located. In 
Figure 5-5, for example, the formula is in cell E4 and the values are in 
the cell range D5:D15.

 • In a row: Enter the values in the row starting one cell above and one 
cell to the right of the cell where the formula is.


